同花顺-圈子

【指标密码】黑马指标主图,买入卖出一目了然
0人浏览 2019-01-30 08:32

一、黑马指标主图

image.png

二、黑马指标应用

1、当出现买入信号时,将会出现比较激进的买点,当天买进;若次日开盘股价跌破前日的阳线实顶,则立马出逃;

2、当出现买入信号时,可以等待次日的开盘,若开盘价价在前日阳线实顶平衡或者之上,则可以考虑买入;

3、若股价一直呈现上升趋势(红色趋势线持续向上)则安心持股;若出现蓝色趋势线,证明拐头已经到来,坚决出逃;

三、黑马指标源代码

VAR3:=LLV(HIGH,240);

VAR4:=100*(CLOSE-VAR3)/VAR3;

VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;

VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;

VAR7:=0;

VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;

VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;

VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);

VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);

VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);

VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);

VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);

VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);

VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);

VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);

VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);

VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);

买1:=VAR10;

买2:=(VAR11+VAR13+VAR15+VAR17);

卖1:=(VAR12+VAR14+VAR16+VAR18);

B:IF(买1>0 OR 买2>0,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;

DRAWTEXT(买1>0 OR 买2>0,LOW*0.99,'买入'),COLORRED;

S:IF(卖1>0,HIGH*1.01,DRAWNULL),CROSSDOT,LINETHICK3,COLORGREEN;

DRAWTEXT(卖1>0,HIGH*1.02,'卖出'),COLORGREEN;



VAR100:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));

VAR200:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));

VAR300:=(100 - MA(((100 * (HHV(HIGH,5) - CLOSE)) / (HHV(HIGH,5) - LLV(LOW,5))),34));

F:IF(CROSS(VAR200,MA(VAR300,5)),LOW * 0.98,DRAWNULL),CROSSDOT,LINETHICK3,COLOREE00EE;

生命线:MA(CLOSE,22),LINETHICK2,COLORRED;

N:=10;

T1:=CONST(HHVBARS(V,N));

T0:IF(CURRBARSCOUNT<=N+3,CONST(IF(T1=0,C,REF(C,T1))),DRAWNULL),COLORFF00FF;

IF(CURRBARSCOUNT=T1+1,T0,DRAWNULL),CIRCLEDOT,COLORFF00FF;

DRAWTEXT(ISLASTBAR,T0,' 量能平台'),COLORCC00CC;



MA135:=MA(VOL,135);

TJ1:=VOL=HHV(VOL,10) AND VOL>1.7*REF(VOL,1) AND C>=REF(C,1) AND C>=O AND VOL<=MA135*3.5;

LJL:=FILTER(TJ1,3);

TJ3:=IF(BARSLAST(LJL)=1 AND CLOSE>REF(LOW,3),1,0);

ST:=TJ3=1;

CL:=FILTER(ST,3);

STICKLINE(LJL,OPEN,CLOSE,1,0),COLORYELLOW;

DRAWTEXT(LJL,L*0.99,'支撑'),COLORF00FF0;

A:MA(C,22)COLORBLUE,,LINETHICK2;

X:=A<REF(A,1);

IF(X-1,A,DRAWNULL)COLORRED,,LINETHICK2;

MA5:=MA(CLOSE,5),COLORWHITE;

MA10:=MA(CLOSE,10),COLORYELLOW;

MA30:=MA(CLOSE,30),COLORMAGENTA;

MA60:=MA(CLOSE,60),COLORGREEN;

MA120:=MA(CLOSE,120),COLORLIMAGENTA;

MA240:=MA(CLOSE,240),COLORBLUE,NODRAW; 

VOL5:=MA(VOL,5),COLORWHITE;

VOL10:=MA(VOL,10),COLORYELLOW;

VOL40:=MA(VOL,20),COLORFF00FF ;

量托:=VOL5>=VOL40 AND CROSS(VOL10,VOL40) AND REF(VOL10,1)<REF(VOL40,1);

DRAWTEXT(量托,L-0.012,'量托'),COLORWHITE;

AA1:=BARSLAST(MA60>MA30 AND (MA30=MA10 OR MA30>MA10));

BB1:=REF(COUNT(C<MA60,AA1)=AA1,1);

CC1:=CROSS(C,MA60) AND VOL>MA(VOL,5) AND (C-REF(C,1))/REF(C,1)*100>3;

芙蓉出水:=BB1 AND CC1,COLOR00FF00;

DRAWTEXT(芙蓉出水,H+0.3,'芙蓉出水'),COLORFF00FF;

STICKLINE(芙蓉出水,H,L,1,1),COLORFF00FF;

STICKLINE(芙蓉出水,O,C,3,1),LINETHICK2,COLORFF00FF;

MA1:=MA(CLOSE,5);

MA2:=MA(CLOSE,10);

MA3:=MA(CLOSE,20);

ZJ:=AMOUNT/10000;{资金}

TM:=V-MA(V,10);{量填满}

一穿三:=MA1>O AND MA2>O AND MA3>O AND MA1<C AND MA2<C AND MA3<C AND CLOSE>OPEN ;

DRAWTEXT(一穿三,L-0.012,'一穿三'),COLORFF00FF;

STICKLINE(一穿三,OPEN,CLOSE,1,0),COLORFF00FF;

TY:=C;

A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10);

A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);

前期高位:REF(C,BARSLAST(HD)),COLORBLUE,POINTDOT;

STICKLINE(C,前期高位,前期高位,8,-1),COLORBLUE; 

{高点:=(C/REF(C,BARSLAST(HD))-1)*100,NODRAW;

STICKLINE((HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667,H,C,0.8,0),COLORBLUE;}

三日不破:=MIN(MIN(L,REF(L,1)),REF(L,2))>=REF(L,3);

三日量缩:=(MAX(MAX(V,REF(V,1)),REF(V,2))<REF(V,3));

三日价涨A:=C>=REF(C,1);

三日价涨B:=C<REF(C,1);

三日价涨C:=MIN(MIN(C,REF(C,1)),REF(C,2))>=REF(L,3);

TIM:=IF(DATE<1140214,1,0);

缩倍柱:=(VOL*1.95<=REF(VOL,1))*TIM;

百日低量:=(VOL=LLV(VOL,100))*TIM;

倍量柱:=C>REF(C,1)*1.04 AND (VOL>=1.9*REF(VOL,1))*TIM;

四日前倍量柱:=(REF(VOL,3)>1.9*REF(VOL,4))*TIM;

四日前高量柱:=(REF(VOL,3)>=REF(VOL,4) AND REF(VOL,3)<1.9*REF(VOL,4) AND 三日量缩)*TIM;

前三引用不成立:=COUNT(REF(四日前倍量柱,1) AND (REF(三日不破,1) OR REF(三日价涨C,1)),3)=0 AND COUNT(REF(四日前高量柱,1) AND (REF(三日不破,1) OR REF(三日价涨C,1)),3)=0;

倍量黄金柱:=四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立;

高量黄金柱:=四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立;

黄金柱:=倍量黄金柱 OR 高量黄金柱;

次倍量黄金柱:=NOT(黄金柱) AND 四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立;

次高量黄金柱:=NOT(黄金柱) AND 四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立;

次黄金柱:=次倍量黄金柱 OR 次高量黄金柱;

准倍量黄金柱:=NOT(黄金柱 OR 次黄金柱) AND 四日前倍量柱 AND ((三日量缩 AND 三日价涨C) OR (COUNT(倍量柱,3)>=1 AND 三日不破)) AND 前三引用不成立;

准高量黄金柱:=NOT(黄金柱 OR 次黄金柱) AND 四日前高量柱 AND (三日量缩 AND 三日价涨C) AND 前三引用不成立;

准黄金柱:=准倍量黄金柱 OR 准高量黄金柱;

倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱) AND 四日前倍量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立;

高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱) AND 四日前高量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立;

将军柱:=倍量将军柱 OR 高量将军柱;

次倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱) AND 四日前倍量柱 AND 三日不破 AND 三日价涨B AND 前三引用不成立;

次高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱) AND 四日前高量柱 AND 三日不破 AND 三日价涨B AND 前三引用不成立;

次将军柱:=次倍量将军柱 OR 次高量将军柱;

准倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱) AND 四日前倍量柱 AND 三日价涨C AND 前三引用不成立;

准高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱) AND 四日前高量柱 AND 三日价涨C AND 前三引用不成立;

准将军柱:=准倍量将军柱 OR 准高量将军柱;

BACKSET100:=BACKSET(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱 OR 准将军柱,4);

FILTER100:=FILTER(BACKSET100,3),NODRAW;

BACKSET101:=BACKSET(黄金柱,4);

FILTER101:=FILTER(BACKSET101,3);

BACKSET102:=BACKSET(次黄金柱,4);

FILTER102:=FILTER(BACKSET102,3);

BACKSET103:=BACKSET(准黄金柱,4);

FILTER103:=FILTER(BACKSET103,3);

BACKSET104:=BACKSET(将军柱,4);

FILTER104:=FILTER(BACKSET104,3);

BACKSET105:=BACKSET(次将军柱,4);

FILTER105:=FILTER(BACKSET105,3);

BACKSET106:=BACKSET(准将军柱,4);

FILTER106:=FILTER(BACKSET106,3);

黄金线下影线:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<=REF(L,3);

黄金线实体下端:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<=MIN(REF(C,3),REF(O,3)) AND MIN(MIN(L,REF(L,1)),REF(L,2))>REF(L,3),LINETHICK0;

黄金线上影线:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>=REF(H,3);

黄金线实体上端:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>=MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<REF(H,3);

黄金线实体中间:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3));

黄金线实体中间1:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3)) AND REF(L,2)=MIN(MIN(L,REF(L,1)),REF(L,2));

黄金线实体中间2:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3)) AND REF(L,1)=MIN(MIN(L,REF(L,1)),REF(L,2));

黄金线实体中间3:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3)) AND L=MIN(MIN(L,REF(L,1)),REF(L,2));

BACKSET201:=BACKSET(黄金线下影线,4);

FILTER201:=FILTER(BACKSET201,3),NODRAW;

BACKSET202:=BACKSET(黄金线实体下端,4);

FILTER202:=FILTER(BACKSET202,3),NODRAW;

BACKSET203:=BACKSET(黄金线上影线,4);

FILTER203:=FILTER(BACKSET203,3),NODRAW;

BACKSET204:=BACKSET(黄金线实体上端,4);

FILTER204:=FILTER(BACKSET204,3),NODRAW;

BACKSET205:=BACKSET(黄金线实体中间,4);

FILTER205:=FILTER(BACKSET205,3),NODRAW;

BACKSET2051:=BACKSET(黄金线实体中间1,4);

FILTER2051:=FILTER(BACKSET2051,3),NODRAW;

BACKSET2052:=BACKSET(黄金线实体中间2,4);

FILTER2052:=FILTER(BACKSET2052,3),NODRAW;

BACKSET2053:=BACKSET(黄金线实体中间3,4);

FILTER2053:=FILTER(BACKSET2053,3),NODRAW;

BT201:=IF(BARSLAST(FILTER201)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER201));

BT202:=IF(BARSLAST(FILTER202)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER202));

BT203:=IF(BARSLAST(FILTER203)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER203));

BT204:=IF(BARSLAST(FILTER204)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER204));

BT205:=IF(BARSLAST(FILTER205)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER205));

BT2051:=IF(BARSLAST(FILTER2051)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER2051));

BT2052:=IF(BARSLAST(FILTER2052)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER2052));

BT2053:=IF(BARSLAST(FILTER2053)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER2053));

最近黄金线:=MIN(MIN(MIN(MIN(MIN(MIN(BT201,BT202),BT203),BT204),BT2051),BT2052),BT2053);

DAY1:=SUMBARS(FILTER100,1),NODRAW;

HJX1_1:=IF(SUMBARS(FILTER201,1)=DAY1,IF(DAY1=1,LOW,REF(LOW,DAY1-1)),0),NODRAW;

HJX1_2:=IF(SUMBARS(FILTER202,1)=DAY1,IF(DAY1=1,MIN(C,O),MIN(REF(C,DAY1-1),REF(OPEN,DAY1-1))),0),NODRAW;

HJX1_3:=IF(SUMBARS(FILTER203,1)=DAY1,IF(DAY1=1,HIGH,REF(HIGH,DAY1-1)),0),NODRAW;

HJX1_4:=IF(SUMBARS(FILTER204,1)=DAY1,IF(DAY1=1,MAX(C,O),MAX(REF(C,DAY1-1),REF(OPEN,DAY1-1))),0),NODRAW;

HJX1_51:=IF(SUMBARS(FILTER2051,1)=DAY1,IF(DAY1=2,LOW,IF(DAY1<2,DRAWNULL,REF(LOW,DAY1-2))),0),NODRAW;

HJX1_52:=IF(SUMBARS(FILTER2052,1)=DAY1,IF(DAY1=3,LOW,IF(DAY1<3,DRAWNULL,REF(LOW,DAY1-3))),0),NODRAW;

HJX1_53:=IF(SUMBARS(FILTER2053,1)=DAY1,IF(DAY1=4,LOW,IF(DAY1<4,DRAWNULL,REF(LOW,DAY1-4))),0),NODRAW;

黄金线:=HJX1_1+HJX1_2+HJX1_3+HJX1_4+HJX1_51+HJX1_52+HJX1_53,COLORYELLOW,NODRAW;

立桩量:=VOL=HHV(VOL,40) AND VOL>1.9*REF(VOL,1);

立桩量三日突破:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));

立桩量三日不破:=BARSLAST(立桩量)=3 AND REF(LOW,3)<=MIN(MIN(C,REF(C,1)),REF(C,2));

BACKSET300:=BACKSET(立桩量三日不破,4);

BACKSET301:=BACKSET(立桩量三日突破,4);

立桩量成立:=FILTER(BACKSET300,3) AND BACKSET301 AND 立桩量;

DRAWTEXT(立桩量成立,HIGH*1.01,'↙立桩量'),COLOR00FF00;

DRAWTEXT(FILTER101,LOW*0.986,'↖黄金柱'),COLORYELLOW;

STICKLINE(FILTER101,OPEN,CLOSE,0.5,0),COLORYELLOW;

DRAWTEXT(FILTER102,LOW*0.986,'↖次黄金柱'),COLORYELLOW;

DRAWTEXT(FILTER104,LOW*0.986,'↖将军柱'),COLORYELLOW;

STICKLINE(FILTER104,OPEN,CLOSE,1.5,0),COLORYELLOW;

K1:=SUMBARS(FILTER104,1);

STICKLINE(K1,REF(L,K1-2),REF(L,K1-2),10,0),COLORYELLOW; 

K2:=SUMBARS(FILTER101,1);

STICKLINE(K2,REF(L,K2-2),REF(L,K2-2),10,0),COLORYELLOW; 

X1:=(C+L+H)/3;

BB5:=ATAN(EMA(X1,7)-REF(EMA(X1,7),1))*3.1416*10;

EMA3:=EMA(C,3);

DRAWTEXT(FILTER(BB5>1 AND EMA(X1,7)>REF(EMA(X1,7),1),10),

LOW*0.99,'★∠45'),COLORFFFFFF;


四、更多指标

播主会不定期分享指标源代码在服务包中,想提前获得更多的指标代码,可以按以下图示进行开户,开户申请后会有工作人员,及时发送代码。



更多
· 推荐阅读
2
1
扫码下载股市教练,随时随地查看更多精彩文章
发 布
所有评论(0
  • 暂时还没有人评论
  • 0
  • TOP
该观点为投顾个人看法,不代表其所属券商和同花顺平台建议。
观点仅供参考,投资有风险,入市需谨慎!